Jump to content
dutchy77

Strange UV issue exporting from Blender to Nifskope

Recommended Posts

Hey folks,

First of all, you guys are amazing, I've spent hours checking out all the stuff you've all made, and i'm well inspired.

Hoping someone might be able to help with a Nifskope/Blender issue i'm having?
I'm a relative newcomer to modding, I've pretty much figured out blender well enough after a couple weeks of trial and error, trouble is getting into Nifskope.

I had trouble with it much earlier on, and put it off till now to figure out what i'm doing wrong because i can't find any instance of anyone else having this issue on any forum anywhere.

I've used the two tutorials hidden away on dark creations/beyond Skyrim about converting to .Nif from Blender 2.79, and i'm pretty sure i'm at least doing everything those tutorials instruct me too. but i'm still getting this result on opening in Nifskope:nifproblem.thumb.png.78fbacde66368598cf5

Rather than what it should look like:

nifproblem2.thumb.png.1447b76760d9a9a8e1

It's meant to be the Redoran style Warhammer based off the concept art off, J'zhargo i think? it's a work in progress... thoughts?

Anyway, the plot thickens.. i thought it was some UV issue where the uv map didn't export with the object out of blender.
But that's not that case, because that weird normalmapish colour dissapates when you zoom into the model, and then does actually display the proper texture:

nifproblem3.thumb.png.6c6082a10dd5cbc482

but only super up close. and that can't be right.  

This only occurs to Nifs I've exported from blender, in game and other modded Nifs load up just fine.

Has anyone more intelligent than me come across this and fixed it? 
Please halp. I've got so much content already made in blender, and cant get any further than this! 

Hoping you wise modders know where i'm going wrong..

Cheers!

 

 

 

Share this post


Link to post
Share on other sites

Hey, sorry, it's for Skyrim

 

I exported as a nif for skyrim, i made sure of that. 

But your nif structure clearly says it's Oblivion nif file. Maybe you didn't choose Game:Skyrim in export settings? And maybe that's the source of your problem. Anyway I would advice you to reexport your object then just delete bsshaderlightproperty from your nif file and copy\paste bsshaderlightproperty  from vanilla nif

Share this post


Link to post
Share on other sites

Hey thanks for replying by the way!

 

Yup, you were right i must've missed checking it to Skyrim on that one. Sadly, after doing it right this time it seems to still be doing the same thing...

nifproblem.thumb.png.24524a63f2c936e1d9b

That's a Skyrim structure nif file no?

funny that it has the same issue whether i export as oblivion or skyrim... i guess i must be doing something pretty wrong still...

 

I'll try and figure out your other advice regarding the bsshaderlightproperty and see what happens..

 

and again, Cheers for helping me out. I really appreciate it!

 

 

Share this post


Link to post
Share on other sites

Hey thanks for replying by the way!

 

Yup, you were right i must've missed checking it to Skyrim on that one. Sadly, after doing it right this time it seems to still be doing the same thing...

nifproblem.thumb.png.24524a63f2c936e1d9b

That's a Skyrim structure nif file no?

funny that it has the same issue whether i export as oblivion or skyrim... i guess i must be doing something pretty wrong still...

 

I'll try and figure out your other advice regarding the bsshaderlightproperty and see what happens..

 

and again, Cheers for helping me out. I really appreciate it!

 

 

Yeah that's Skyrim this time.

Well, I see a normal map assigned as diffuse and no diffuse map at all. Just tap on your normal map address (textures/***/yournormalmap.dds), copy the file path and paste it 1 string below (on a second string, where normal map should be placed)

Then change file path on the first string so it would point to your diffuse map (textures/***/yourdiffusemap.dds

small flower icon and choose he way to your diffuse map

Edited by Mirrou4ka

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×